Live Chat maintenance
Incident Report for Heart Internet
Resolved
Live Chat maintenance has been completed.
Posted Nov 18, 2020 - 12:03 GMT
Investigating
Our live chat facility will be temporarily offline. Ticket based and telephone support is still operating as normal.

We apologise for any inconvenience caused.
Posted Nov 17, 2020 - 08:28 GMT