Webmail (outitgoes.com)
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Sep 30, 2020 - 04:06 BST
Investigating
We're aware of an issue with our webmail system (outitgoes.com). We're working on it. Thanks for your patience.
Posted Sep 30, 2020 - 01:54 BST
This incident affected: Mailservers.