Issues processing payments
Incident Report for Heart Internet
Resolved
This has now been resolved. If you have attempted any payments during this time please retry these now and raise a support ticket if you continue to experience any problems.
Posted May 04, 2023 - 20:19 BST
Investigating
We are seeing issues for some customers when processing payments which we are currently investigating further
Posted May 04, 2023 - 19:54 BST
This incident affected: Control Panels.