Mail delivery issues
Incident Report for Heart Internet
Resolved
19:08 - This has now been resolved.
Posted Mar 31, 2020 - 19:06 BST
Monitoring
All connectivity has been resumed and we are monitoring the situation, we apologise for any inconvience caused.
Posted Mar 31, 2020 - 14:38 BST
Update
We have also been made aware that this is also affecting websites / connectivity to webservers with certain Internet service providers.
Posted Mar 31, 2020 - 11:02 BST
Investigating
We have been made aware of email connectivity issues with some customers across our mail platform, we are currently investigating links between this and problems with certain Internet service providers.

We apologise for any inconvience caused.
Posted Mar 31, 2020 - 10:51 BST