cPanel Hosting
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Mar 09, 2021 - 03:11 GMT
Investigating
We're aware of an issue with some customers on the cPanel Hosting product. We're working on it. Thanks for your patience.
Posted Mar 09, 2021 - 02:19 GMT