Live Chat Unavailable
Incident Report for Heart Internet
Resolved
Live chat is available again.
Posted Dec 19, 2019 - 10:05 GMT
Investigating
Our live chat service is currently unavailable. We apologise for any inconvenience caused.
Posted Dec 19, 2019 - 08:58 GMT