Live Chat maintenance
Incident Report for Heart Internet
Resolved
Live chat service has now been restored.
Posted Aug 13, 2020 - 09:56 BST
Investigating
Our live chat facility will be temporarily offline. Ticket based and telephone support is still operating as normal.

We apologise for any inconvenience caused.
Posted Aug 12, 2020 - 14:08 BST