Planned Maintenance
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Oct 21, 2022 - 16:33 BST
Investigating
Our support channels will be unavailable between 13:30 and 14:30 due to planned maintenance. You will still be able to raise a ticket during this period, however responses will be delayed, but our live chat however will be closed during this time. Thank you for your patience and understanding.
Posted Oct 21, 2022 - 10:27 BST