Sucuri Website Security access issues
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Jul 21, 2020 - 15:01 BST
Investigating
Some customers may experience issues in accessing their Sucuri Website Security management page through their control panel. This is currently being investigated and we aim to resolve this as soon as possible. We apologise for any inconvenience caused.
Posted Jul 21, 2020 - 14:16 BST
This incident affected: Control Panels.