Outitgoes.com webmail login issues
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Jan 26, 2022 - 18:28 GMT
Investigating
We are seeing some reports of errors logging into webmail at outitgoes.com and are currently investigating. Connections from other email clients appear unaffected.
Posted Jan 26, 2022 - 17:27 GMT
This incident affected: Mailservers.