Support Team Availability on 18th December
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Dec 22, 2020 - 13:47 GMT
Monitoring
Our telephone, live chat, and tickets support teams will be unavailable on the 18th December between 15:30-16:00 GMT due to team training.

We apologise for any inconvenience this may cause.
Posted Dec 17, 2020 - 10:00 GMT