Mail Connectivity Issues
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Jul 21, 2020 - 13:35 BST
Investigating
We're looking into reports of failed connections to mail servers. We'll provide some updates as soon as possible.
Posted Jul 21, 2020 - 10:47 BST
This incident affected: Mailservers.