Shared Mail abnormal server behaviour
Incident Report for Heart Internet
Resolved
Our Engineering teams have reported that the processing queue and mail platform has returned to normal operation.

If you are experiencing issues with email delivery or connectivity, please raise a support ticket from the Customer Area.
Posted May 23, 2023 - 10:24 BST
Monitoring
We've identified and resolved the underlying issue on Shared Mail platform, new emails should be delivered as normal.

Emails that entered the processing queue this morning should be delivered within the next 6-8 hours of this update (15:10 BST).
Posted May 22, 2023 - 15:11 BST
Investigating
We're aware of an issue affecting mail activity on the Shared Mail platform. This is being investigated, additional information will be provided when available.

We apologise for any inconvenience caused.
Posted May 22, 2023 - 10:49 BST
This incident affected: Mailservers.