Delays in Ticket Response Times
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Mar 30, 2021 - 08:47 BST
Identified
Due to unprecedented number of contacts, you may experience delays in our responses to your support requests. Our teams are working hard to ensure we respond to every request.

We apologise for any inconvenience caused during this time.
Posted Jan 19, 2021 - 10:19 GMT