Issues logging into customer control panel
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Aug 22, 2022 - 13:29 BST
Investigating
We are currently seeing intermittent issues with logging into the customer control panel and are investigating.
Posted Aug 22, 2022 - 12:55 BST
This incident affected: Control Panels.