Mail174 - abnormal server behaviour
Incident Report for Heart Internet
Resolved
This has now been resolved. Please note that affected mailboxes have been reassigned to mail177.
Posted Apr 22, 2022 - 22:22 BST
Identified
We are currently seeing abnormal behaviour on this server, we are investigating and hope to get this working as soon as possible.

We apologise for any inconvenience caused.
Posted Apr 22, 2022 - 16:28 BST