Dedicated Server Connectivity Issues
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted May 27, 2020 - 18:24 BST
Investigating
We're aware of connectivity issues with a small number of dedicated servers. We're looking into this.
Posted May 27, 2020 - 17:46 BST
This incident affected: Dedicated Servers.