PDF Invoices
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Feb 13, 2021 - 15:18 GMT
Identified
The issue has been identified and a fix is being implemented.

We apologise for any inconvenience caused regarding this.
Posted Feb 12, 2021 - 23:03 GMT
Investigating
We are currently investigating a problem with pdf invoices in customer accounts, this may prevent some customers from being able to view them at the moment.

We apologise for any inconvenience caused regarding this.
Posted Feb 12, 2021 - 19:21 GMT