Live Chat Unavailable
Incident Report for Heart Internet
Resolved
Our live chat facility is now online.
Posted Apr 16, 2020 - 09:15 BST
Investigating
Our live chat facility will be temporarily offline. Ticket based and telephone support is still operating as normal.

We apologise for any inconvenience caused.
Posted Apr 15, 2020 - 13:23 BST