Mail37 Abnormal Server Behaviour
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Oct 19, 2017 - 13:20 BST
Identified
We are seeing loss of external connectivity to this mail server, our system administrators are currently investigating this issue and are working to resolve the problem. We hope to have this back to normal operations as soon as possible and also apologise for any inconveniences caused.
Posted Oct 19, 2017 - 11:36 BST