Windows Platform Maintenance
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 03, 2017 - 10:31 BST
Investigating
We are currently performing maintenance work on our Windows platform, we do not expect there to be any downtime.
Posted 5 months ago. Jul 25, 2017 - 10:34 BST
This incident affected: Webservers.