Mail47 abnormal server behaviour
Incident Report for Heart Internet
Resolved
This has now been resolved.
Posted 3 months ago. Aug 02, 2019 - 11:51 BST
Investigating
We are currently seeing abnormal behaviour on Mail47, we are investigating and hope to get this working as soon as possible.

We apologise for any inconvenience caused.
Posted 3 months ago. Aug 02, 2019 - 11:25 BST
This incident affected: Mailservers.