Mail Server "mail177"
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 06, 2018 - 07:28 BST
Identified
The shared hosting mail server "mail177" has been experiencing intermittent connectivity and mail delivery issues. We are aware of the problem and are working to resolve this as soon as possible. Apologies for any inconvenience caused.
Posted 4 months ago. Aug 02, 2018 - 08:06 BST
This incident affected: Mailservers.