Domain operations
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 4 months ago. May 09, 2017 - 10:19 BST
Update
Update 21:50 - We are still looking into resolving the issue with domain registrations, searches and nameserver changes, who.is privacy altering. We apologise for any inconvenience caused regarding this.
Posted 4 months ago. May 08, 2017 - 21:51 BST
Investigating
Certain domain operations, such as registrations, searches and nameserver changes, are temporarily unavailable while our domain registry works to resolve this. We hope to have everything back to normal very shortly.
Posted 4 months ago. May 08, 2017 - 08:59 BST