Phone line temporarily unavailable
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Nov 05, 2019 - 14:18 GMT
Investigating
Our 0330 660 0255 telephone number is currently unavailable, if you wish to get in contact with us via telephone please use our alternative number: (+44) 207 023 9001.
We hope to have this resolved as soon as possible.
Posted Nov 05, 2019 - 13:43 GMT