Mail 49 - Connectivity Problems
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 23, 2018 - 15:49 BST
Investigating
We are currently seeing abnormal behaviour on this server, and are investigating the causes.
We expect to have it back to normal operation soon, and apologise for any inconvenience caused.
Posted 3 months ago. Jul 22, 2018 - 13:23 BST
This incident affected: Mailservers.