Mail134 - abnormal server behaviour
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 14, 2019 - 21:51 GMT
Investigating
We are currently seeing abnormal behaviour on this server and are investigating the causes, customers affected are unable to send/receive or access their mailboxes.

We expect to have it back to normal operation soon, and apologise for any inconvenience caused.
Posted 7 months ago. Mar 14, 2019 - 20:07 GMT