Mail39 abnormal server behaviour
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 19 days ago. Sep 27, 2019 - 18:01 BST
Identified
The issue has been identified and a fix is being implemented.
Posted 19 days ago. Sep 27, 2019 - 17:45 BST
Investigating
We are currently seeing abnormal behaviour on Mail39, we are investigating and hope to get this working as soon as possible.

We apologise for any inconvenience caused.
Posted 19 days ago. Sep 27, 2019 - 16:58 BST