Mail114 abnormal server performance
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 11 days ago. Aug 12, 2017 - 13:20 BST
Identified
We are currently having adverse performance on this server which is affecting the processing and delivery of emails coming into this mail-server. We are investigating the cause and expect to have it back to normal operation as soon as possible. We apologise for any inconvenience caused.
Posted 11 days ago. Aug 12, 2017 - 11:26 BST