Email deliverability - connectivity issues
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 01, 2019 - 14:49 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Aug 01, 2019 - 13:43 BST
Investigating
We are currently seeing abnormal behaviour on mailservers, we are aware that customers are having issues receiving/sending emails using our mailservers.

We are investigating and hope to get this working as soon as possible.

We apologise for any inconvenience caused.
Posted 2 months ago. Aug 01, 2019 - 12:56 BST