Registry connectivity issues
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 03, 2017 - 08:50 BST
Investigating
We're currently investigating reports of disruption to domain-related services, including domain renewals and registrations. We hope to have this resolved as soon as possible. Any domain-related changes will be delayed in the meantime.
Posted 3 months ago. Aug 01, 2017 - 09:14 BST