Mail61 - Mail Delivery Problems
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 05, 2019 - 12:52 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Aug 05, 2019 - 12:43 BST
Investigating
We are currently seeing abnormal behaviour on this server, we are investigating and hope to get this working as soon as possible.

We apologise for any inconvenience caused.
Posted 2 months ago. Aug 05, 2019 - 12:30 BST