Mail server performance - Abnormal behaviour for mail119 and mail61
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 2 months ago. May 17, 2019 - 14:39 BST
Investigating
Mail61 and mail119 are currently suffering from Abnormal behaviour. We are aware and are investigating these issues and hope to have this resolved soon.
Posted 2 months ago. May 17, 2019 - 11:57 BST
This incident affected: Mailservers.