Kvmhost88 - abnormal server behaviour
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 28, 2019 - 19:24 BST
Investigating
We are currently seeing abnormal behaviour on this KVMhost, we are investigating and hope to get this working as soon as possible.

We apologise for any inconvenience caused.
Posted 3 months ago. Jun 28, 2019 - 18:37 BST