mail74, mail75, mail84, mail85
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 11 days ago. Nov 30, 2017 - 14:35 GMT
Monitoring
Some mailboxes on these servers will be seeing connectivity issues while their migrations complete. No incoming email will be lost.
Posted 12 days ago. Nov 30, 2017 - 08:57 GMT