Abnormal server behaviour on Mail Servers
Incident Report for Heart Internet
Resolved
This has now been resolved.
Posted 22 days ago. Oct 30, 2018 - 00:04 GMT
Investigating
We're currently experiencing some temporary issues with the following mail servers:

Mail 140
Mail 141
Mail 143
Mail 144
Mail 145

Customers may experience delays in their emails. We apologise for any inconveniences.
Posted 22 days ago. Oct 29, 2018 - 14:19 GMT
This incident affected: Mailservers.