mail124 Abnormal Server Behaviour
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 7 days ago. May 17, 2019 - 16:57 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 7 days ago. May 17, 2019 - 15:46 BST
Investigating
We are aware of abnormal behaviour on mail124. Our teams will work to rectify this as soon as possible.
Posted 7 days ago. May 17, 2019 - 14:40 BST
This incident affected: Mailservers.