Domain services and Premium Hosting issues
Incident Report for Heart Internet
Resolved
This issue has now been resolved.
Posted about 2 months ago. Oct 13, 2017 - 09:34 BST
Investigating
Customers may experience some issues regarding registering, renewing and updating nameservers on domains and creating and some aspects of managing Premium Hosting packages. We are currently aware of the issue and are working towards a resolution. Thank you for your understanding.
Posted 2 months ago. Oct 12, 2017 - 15:49 BST