mail177
Incident Report for Heart Internet
Resolved
This has been completed.
Posted 12 days ago. Nov 29, 2017 - 18:23 GMT
Monitoring
Access to mailboxes on mail177 will be inconsistent while a migration procedure to a brand new mailserver completes. Our apologies for any inconveniences.
Posted 15 days ago. Nov 26, 2017 - 10:40 GMT