Registry connectivity
Incident Report for Heart Internet
Resolved
This has been resolved.
Posted 6 months ago. Jan 10, 2018 - 09:04 GMT
Investigating
There is currently a problem affecting the registration and management of domain names, we are investigating this and we apologise for any inconvenience caused.
Posted 6 months ago. Jan 08, 2018 - 23:01 GMT