All Systems Operational
Control Panels Operational
DNS Operational
Webservers Operational
Mailservers Operational
Premium Hosting Operational
VPS & Hybrid Servers Operational
Dedicated Servers Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Past Incidents
Mar 28, 2024

No incidents reported today.

Mar 27, 2024

No incidents reported.

Mar 26, 2024

No incidents reported.

Mar 25, 2024

No incidents reported.

Mar 24, 2024

No incidents reported.

Mar 23, 2024

No incidents reported.

Mar 22, 2024

No incidents reported.

Mar 21, 2024
Resolved - This incident has been resolved.
Mar 21, 15:42 GMT
Monitoring - A fix has been implemented and we are monitoring the results.
Mar 21, 14:27 GMT
Investigating - Our systems team have identified a problem on this cluster, which requires some emergency maintenance to be undertaken. Sites hosted on these servers will be unavailable while the maintenance is under way. We will provide further details when we have them.
Mar 21, 12:36 GMT
Completed - The scheduled maintenance has been completed.
Mar 21, 15:30 GMT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 21, 13:00 GMT
Scheduled - Our live chat lines will be closed between 1pm and 2:30pm. If you require assistance from the support team please contact them by raising a ticket in your account.
Mar 21, 12:39 GMT
Resolved - This incident has been resolved.
Mar 21, 11:09 GMT
Identified - The issue has been identified and a fix is being implemented.
Mar 21, 10:57 GMT
Investigating - We are currently investigating a problem with mailbox access that is affecting some customers.
Mar 21, 10:44 GMT
Mar 20, 2024

No incidents reported.

Mar 19, 2024

No incidents reported.

Mar 18, 2024

No incidents reported.

Mar 17, 2024

No incidents reported.

Mar 16, 2024

No incidents reported.

Mar 15, 2024

No incidents reported.

Mar 14, 2024

No incidents reported.