web71 web72 web73 web74 web180 web181 web182 web183 database abnormal server performance
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 2 months ago. May 19, 2017 - 12:09 BST
Investigating
We are currently investigating this issue.
Posted 2 months ago. May 18, 2017 - 12:02 BST