Windows FTP
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Apr 12, 2017 - 14:20 BST
Identified
Our administrators are aware of an issue concerning FTP on Windows packages, and hope to have it resolved soon.
Posted Apr 12, 2017 - 14:03 BST