Connectivity issues with Mail129
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 17, 2018 - 00:25 BST
Identified
We're aware of an issue with Mailserver 129. We're working on it, thanks for your patience.
Posted 6 months ago. Apr 17, 2018 - 00:00 BST
This incident affected: Mailservers.