Shared Hosting - Email Problem
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 09, 2018 - 20:33 GMT
Investigating
We're aware of an issue with the shared email platform, we are working on getting this resolved. Thanks for your patience.
Posted 3 months ago. Mar 09, 2018 - 18:33 GMT