Mail61 Connectivity Problem
Incident Report for Heart Internet
Resolved
Connections to the mail server have been restored.
Posted 14 days ago. Aug 07, 2019 - 22:28 BST
Investigating
We are currently experiencing some adverse connection problems to this mail server, as a result some users my not be able to connect to their mailboxes on the server. Our system administrators are currently investigating this and we hope to have it back to normal as soon as possible.
Posted 14 days ago. Aug 07, 2019 - 13:42 BST