mail119 - Abnormal Server Performance
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Apr 13, 2017 - 19:22 BST
Update
We are seeing some further issues with the performance of this Mail Server and our System Administration Team are working on this further.
Posted Apr 13, 2017 - 18:27 BST
Investigating
We are currently seeing issues with logging into Mailboxes on this server.

We are aware of the issue and are working on correcting this and apologise for the inconvenience caused.
Posted Apr 13, 2017 - 15:53 BST