mail61 connectivity issues
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 12 days ago. Oct 03, 2019 - 12:41 BST
Monitoring
Server has now resumed it's email operations. We will continue to monitor this for the time being.
Posted 12 days ago. Oct 03, 2019 - 10:36 BST
Investigating
We are currently experiencing some issues with connectivity to email services on mail61. We are investigating this and aim to resolve this as soon as possible.

We apologise for any inconvenience caused by this.
Posted 12 days ago. Oct 03, 2019 - 09:30 BST
This incident affected: Mailservers.