Shareddb2 potential issue.
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Feb 15, 2018 - 21:37 GMT
Investigating
We're aware of an issue with Shareddb2. We're working on it. Thanks for your patience.
Posted Feb 15, 2018 - 20:45 GMT