Mail72 - Mail Delivery Problems
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 01, 2019 - 10:20 BST
Investigating
We are aware that users of the Mail72 sever have encountered issues today sending to Microsoft (Hotmail & Office 365).

Our System Administrators are currently working on delisting the server, we apologise for any inconvenience caused.
Posted 3 months ago. Mar 28, 2019 - 15:33 GMT